hdu 1542 Atlantis 线段树求面积并,,,尼玛数据真坑人,数组千万不能开小!

Atlantis

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7815    Accepted Submission(s): 3420


Problem Description
There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.
 

Input
The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.

The input file is terminated by a line containing a single 0. Don’t process it.
 

Output
For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.

Output a blank line after each test case.
 

Sample Input
2 10 10 20 20 15 15 25 25.5 0
 

Sample Output
Test case #1 Total explored area: 180.00
求面积并:
推荐博客:http://www.cnblogs.com/ka200812/archive/2011/11/13/2247064.html
我的代码:
#include <cstdio>
#include <algorithm>

using namespace std ;

double y[300] ;

struct Line{
	double x , y_up , y_down ;
	int mark ;
}line[300] ;		//开始开到110,WA另外三次!!后来看discuss改后就A了! 

struct Node{
	double x ,y_up,y_down ;
	int cover ;
	bool isLeaf ;
}st[400100];

bool cmp(const Line &a , const Line &b)
{
	return a.x<b.x ;
}

void build(int l ,int r , int pos)
{
	st[pos].cover = 0 ;
	st[pos].y_down = y[l] ;
	st[pos].y_up = y[r] ;
	st[pos].x = -1 ;
	st[pos].isLeaf = false ;
	if(l+1 == r)
	{
		st[pos].isLeaf = true ;
		return ;
	}
	int mid = (l+r)>>1 ;
	build(l,mid,pos<<1);
	build(mid,r,pos<<1|1) ;
}

double insert(double x , double y_up , double y_down , int mark , int pos)
{
	if(st[pos].y_down>=y_up || st[pos].y_up<=y_down)
	{
		return 0 ;
	}
	if(st[pos].isLeaf)
	{
		if(st[pos].cover>0)
		{
			double temp = st[pos].x ;
			double area = (x-temp)*(st[pos].y_up-st[pos].y_down) ;
			st[pos].x = x ;
			st[pos].cover += mark ;
			return area ;
		}
		else
		{
			st[pos].x = x ;
			st[pos].cover += mark ;
			return 0 ;
		}
	}
	return insert(x,y_up,y_down,mark,pos<<1)+insert(x,y_up,y_down,mark,pos<<1|1) ;
}

int main()
{
	int n , c = 1;
	while(~scanf("%d",&n) && n)
	{
		int index = 0 ;
		for(int i = 0 ; i < n ; ++i)
		{
			double x1,y1,x2,y2 ;
			scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2) ;
			line[index].x = x1 ;
			line[index].y_down = y1 ;
			line[index].y_up = y2 ;
			y[index] = y1 ;
			line[index++].mark = 1 ;
			
			line[index].x = x2 ;
			line[index].y_down = y1 ;
			line[index].y_up = y2 ;
			y[index] = y2 ;
			line[index++].mark = -1 ;
		}
		sort(y,y+index) ;
		sort(line,line+index,cmp) ;
		build(0,index-1,1) ;
		double area = 0.0 ;
		for(int i = 0 ; i < index ; ++i)
		{
			area += insert(line[i].x,line[i].y_up,line[i].y_down,line[i].mark,1) ;
		}
		printf("Test case #%d\n",c++) ;
		printf("Total explored area: %.2lf\n\n",area) ;
	}
	return 0 ;
}

与君共勉

郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。