HDU - 1061 Rightmost Digit

Description

Given a positive integer N, you should output the most right digit of N^N.
 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output

For each test case, you should output the rightmost digit of N^N.
 

Sample Input

2 3 4
 

Sample Output

7 6

题意:取N^N的最后一位

思路:裸的快速幂取模

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
typedef long long ll;
using namespace std;

int pow_mod(int a, int n, int m) {
	if (n == 0)
		return 1;
	if (n == 1)
		return a%m;
	int x = pow_mod(a, n/2, m);
	ll ans = (ll) x*x%m;
	if (n % 2 == 1)
		ans = ans * a % m;
	return (int)ans;
}

int main() {
	int t;
	int n;
	scanf("%d", &t);
	while (t--) {
		scanf("%d", &n);
		ll ans = pow_mod(n, n, 10);
		cout << ans << endl;
	}
	return 0;
}



HDU - 1061 Rightmost Digit,古老的榕树,5-wow.com

郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。