算法相关网站

Pat1047代码

Zhejiang University has 40000 students and provides 2500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=40000), the total number of students, and K (<=2500), the total number of courses. Then N lines follow, each contains a student‘s name (3 capital English letters plus a one-digit number), a positive number C (<=20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students‘ names in alphabetical order. Each name occupies a line.

Sample Input:
10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5
Sample Output:
1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
AC代码:
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<vector>
#include<algorithm>

using namespace std;
class Name
{
	public:
	char name[5];
	bool operator<(const Name& b)const
	{
		if(strcmp(this->name,b.name)<0)
			return true;
		else
			return false;
	}
};

int main(int argc,char *argv[])
{
	int N,K;
	int i,j,num;
	int index;
	char name[5];
	vector<Name> course[2501];
	scanf("%d%d",&N,&K);
	getchar();
	for(i=0;i<N;i++)
	{
		scanf("%s %d",name,&num);
		for(j=0;j<num;j++)
		{
			scanf("%d",&index);
			Name n;
			strcpy(n.name,name);
			course[index].push_back(n);
		}
	}
	for(i=1;i<=K;i++)
	{
		printf("%d %lu\n",i,course[i].size());
		sort(course[i].begin(),course[i].end());
		for(j=0;j<course[i].size();j++)
			printf("%s\n",course[i][j].name);
	}

	return 0;
}

这题跟上一题很类似,只需要重载一下operator<函数即可。。。

郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。