POJ 1258 Agri-Net

Agri-Net
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 39730   Accepted: 16145

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

Source


题意:还用说嘛。

思路:最小裸题,还用说嘛。

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <stdlib.h>

using namespace std;

int mp[105][105];
int low[105];
bool vis[105];
int n;

int prim(){
    int pos,minx,res=0;
    memset(vis,false,sizeof(vis));
    vis[1]=true;
    pos=1;
    for(int i=1;i<=n;i++){
        if(i!=pos)
            low[i]=mp[pos][i];
    }
    for(int i=1;i<n;i++){
        minx=10000000;
        for(int j=1;j<=n;j++){
            if(!vis[j]&&minx>low[j]){
                minx=low[j];
                pos=j;
            }
        }
        res+=minx;
        vis[pos]=true;
        for(int j=1;j<=n;j++){
            if(!vis[j]&&low[j]>mp[pos][j])
                low[j]=mp[pos][j];
        }
    }
    return res;
}

int main(){
    while(~scanf("%d",&n)){
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                scanf("%d",&mp[i][j]);
            }
        }
        printf("%d\n",prim());
    }
    return 0;
}




POJ 1258 Agri-Net,古老的榕树,5-wow.com

郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。