NYOJ 483 Nightmare 【广搜】+【无标记】

Nightmare

时间限制:1000 ms  |  内存限制:65535 KB
难度:4
描述
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius‘ start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can‘t get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can‘t use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
输入
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius‘ start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius‘ target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

输出
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

样例输入
2
3 3
2 1 1
1 1 0
1 1 3
4 8
2 1 1 0 1 1 1 0
1 0 4 1 1 0 4 1
1 0 0 0 0 0 0 1
1 1 1 4 1 1 1 3
样例输出
4
-1
896378 长木 Nightmare Accepted 4 308 C/C++ 06-15 21:03:39
896368
长木 Nightmare WrongAnswer -- -- C/C++ 06-15 20:54:57
896363
长木 Nightmare WrongAnswer -- -- C/C++ 06-15 20:49:37
896360
长木 Nightmare WrongAnswer -- -- C/C++ 06-15 20:46:04
896339
长木 Nightmare WrongAnswer -- -- C/C++ 06-15 20:14:06
896333
长木 Nightmare WrongAnswer -- -- C/C++ 06-15 20:02:33
896306
长木 Nightmare WrongAnswer -- -- C/C++ 06-15 19:06:14

说多泪啊(┬_┬),之前几次WA都是数组模拟队列时结果错用成了栈。。

AC:

#include <stdio.h>
#include <queue>
using std::queue;
int map[10][10], t, m, n, id;
int mov[][2] = {1, 0, -1, 0, 0, 1, 0, -1};
struct Node{
	int x, y, steps, time;
} start;
queue<Node> Q;

int check(int i, int j){
	if(i < 0 || j < 0 || i >= m || j >= n)
		return 0;
	return map[i][j];
}

int BFS(){
	Node now, temp;
	while(!Q.empty()){
		now = Q.front();
		Q.pop();
		if(now.time == 1) continue; //cut
		for(int i = 0; i < 4; ++i){
			temp = now;
			temp.x += mov[i][0];
			temp.y += mov[i][1];
			--temp.time; ++temp.steps;
			if(check(temp.x, temp.y)){
				if(map[temp.x][temp.y] == 3) return temp.steps;
				else if(map[temp.x][temp.y] == 4){ //防止无限次充电
					map[temp.x][temp.y] = 1; 
					temp.time = 6;
				}
				Q.push(temp);
			}
		}
	}
	return -1;
}

int main(){
	scanf("%d", &t);
	while(t--){
		scanf("%d%d", &m, &n);
		start.steps = 0;
		start.time = 6;
		for(int i = 0; i < m; ++i)
			for(int j = 0; j < n; ++j){
				scanf("%d", &map[i][j]);
				if(map[i][j] == 2){
					start.x = i; start.y = j;
				}
			}
		while(!Q.empty()) Q.pop();
		Q.push(start);
		printf("%d\n", BFS());
	}
	return 0;
}        
WA:

#include <stdio.h>
int map[10][10], t, m, n, id;
int mov[][2] = {-1, 0, 0, 1, 1, 0, 0, -1};
struct Node{
	int x, y, steps, time;
} Q[70], start;

int check(int i, int j){
	if(i < 0 || j < 0 || i >= m || j >= n)
		return 0;
	return map[i][j];
}

int BFS(){
	Node now, temp;
	while(id){
		now = Q[--id]; //这哪是出队啊,⊙﹏⊙b汗
		if(map[now.x][now.y] == 3) return now.steps;
		if(now.time == 1) continue; //cut
		for(int i = 0; i < 4; ++i){			
			temp = now;
			temp.x += mov[i][0];
			temp.y += mov[i][1];
			--temp.time; ++temp.steps;
			if(check(temp.x, temp.y)){				
				if(map[temp.x][temp.y] == 4){ //防止无限次充电
					map[temp.x][temp.y] = 1; //不能赋值为0,否则可能无限循环
					temp.time = 6;
				}
				Q[id++] = temp;
			}
		}
	}
	return -1;
}

int main(){
	scanf("%d", &t);
	while(t--){
		scanf("%d%d", &m, &n);
		start.steps = id = 0;
		start.time = 6;
		for(int i = 0; i < m; ++i)
			for(int j = 0; j < n; ++j){
				scanf("%d", &map[i][j]);
				if(map[i][j] == 2){
					start.x = i; start.y = j;
				}
			}
		Q[id++] = start;
		printf("%d\n", BFS());
	}
	return 0;
}



NYOJ 483 Nightmare 【广搜】+【无标记】,古老的榕树,5-wow.com

郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。