ZOJ 1586 QS Network (经典MST~Prim)

链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=586

In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS‘s have received the message.

A sample is shown below:


A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS‘s favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.


Input

The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS‘s favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.


Output

for each data set,output the minimum cost in a line. NO extra empty lines needed.


Sample Input

1
3
10 20 30
0 100 200
100 0 300
200 300 0


Sample Output

370


分析:

在构造有向网时,每条边的权值为两个QS的适配器价格加上这两个QS之间的网线的价格,而且不需要记录构造最小生成树时选择的边;


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <queue>
#define MAXN 1005
#define INF 0x1f1f1f1f
#define RST(N)memset(N, 0, sizeof(N))
using namespace std;

int n, res, cas;      //QS适配器的个数,结果,测试数据组数;
int lowcost[MAXN];    //充当Prim算法中的两个数组lowcost和near_vex的作用;
int adapt[MAXN];    //每个QS喜欢的适配器的价格;
int Edge[MAXN][MAXN];  //邻接矩阵;

void Init()
{
    scanf("%d", &n);
    for(int i=0; i<n; i++) scanf("%d", &adapt[i]);   //输入价格;
    for(int i=0; i<n; i++) {
        for(int j=0; j<n; j++) {    //邻接矩阵初始化;
            scanf("%d", &Edge[i][j]);
            if(i == j) Edge[i][j] = INF;
            else Edge[i][j] += (adapt[i]+adapt[j]);
        }
    }
    RST(lowcost), res = 0;
}

void Prim()    //Prim算法核心;
{
    lowcost[0] = -1;    //从顶点0开始构造最小生成树;
    for(int i=1; i<n; i++) lowcost[i] = Edge[0][i];
    for(int i=1; i<n; i++) {     //把其他n-1个顶点扩展到生成树当中;
        int min = INF, k; 
        for(int j=0; j<n; j++) {    //找到当前可用的权值最小的边;
            if(lowcost[j] != -1 && lowcost[j] < min) {
                k = j;
                min = lowcost[j];
            }
        }
        res += min;
        lowcost[k] = -1;    //把顶点k扩展进来;
        for(int i=0; i<n; i++) if(Edge[k][i] < lowcost[i]) {
            lowcost[i] = Edge[k][i];
        }
    }
    printf("%d\n", res);
}

int main()
{
    scanf("%d", &cas);
    while(cas--) {
        Init(), Prim();
    }
    return 0;
}


ZOJ 1586 QS Network (经典MST~Prim),古老的榕树,5-wow.com

郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。