HDU 1541 Stars 树状数组简单应用


Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5140    Accepted Submission(s): 2020


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it‘s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

Sample Input
5 1 1 5 1 7 1 3 3 5 5
 

Sample Output
1 2 1 1 0
 

Source
 

让你求每个点在它左下角有多少个点的个数。按照y坐标从小到的顺序给出每个点坐标。
根据输入的顺序,进行树状数组处理。
//46MS	500K
#include<stdio.h>
#include<string.h>
int C[32007],ans[32007];
int N=32007;
int lowbit(int x)
{
    return x&(-x);
}
void add(int pos,int val)
{
    while(pos<N)
    {
        C[pos]+=val;
        pos+=lowbit(pos);
    }
}
int getsum(int x)
{
    int result=0;
    while(x>0)
    {
        result+=C[x];
        x-=lowbit(x);
    }
    return result;
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(C,0,sizeof(C));
        memset(ans,0,sizeof(ans));
        int x,y;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&x,&y);
            ans[getsum(x+1)]++;
            add(x+1,1);
        }
        for(int i=0;i<n;i++)
            printf("%d\n",ans[i]);
    }
}


郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。