hdu Constructing Roads(最小生成树,kuskal算法)

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14569    Accepted Submission(s): 5530


Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
 

Sample Input
3 0 990 692 990 0 179 692 179 0 1 1 2
 

Sample Output
179
 

Source

题意:
给出总共的村庄的编号,然后在下面的n行n列中,列举出来从i节点,到j节点的所有的权值 ,都为最后输入的那个数,之后在输入q表示有q组数据,表示接下来的q组数据表示已经联通,求出最后的最小生成树的最小权值!
心得 :
读题不慎,读错题。白白浪费了两个小时,都在做这个水题!
代码如下:
#include<stdio.h>
#include<algorithm>
using namespace std;
struct node{
	int a,b,c;
}s[100100];
int father[110];
int cmp(node x,node y)//求最小生成树的最小权值,要求权值和最小,故升序。
{
	return x.c<y.c;
}
int find(int r)//寻找父节点
{
	if(r!=father[r])
	return find(father[r]);
	else
	return father[r];
}
int kuskal(int n,int m)
{
	int i,sum=0,a,b;
	sort(s,s+m,cmp);
	for(i=0;i<m;i++)
	{
		a=s[i].a;
		b=s[i].b;
		a=find(a);
		b=find(b);
		if(a!=b)//运用的稀疏矩阵的下三角矩阵,只计算在在方形矩阵一端即可
		{
			sum+=s[i].c;//并入最小生成树,
			father[a]=b;//父节点合并,即将该节点并入最小生成树
		}
	}
	return sum;//返回最小生成树的最小权值和!
}
int main()
{
	int n,m,i,j,q,a,b,d;
	while(~scanf("%d",&n))
	{
		m=0;
		for(i=1;i<=n;i++)
		father[i]=i;
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
			{
				scanf("%d",&d); 
				if(i>=j)//稀疏矩阵的下三角矩阵
				{
					continue;
				}
				s[m].a=i;
				s[m].b=j;
				s[m].c=d;
				m++;//统计位于下三角矩阵的坐标点
			}
		}
		scanf("%d",&q);
		for(i=0;i<q;i++)
		{
			scanf("%d%d",&a,&b);
			a=find(a);
			b=find(b);
			father[a]=b;
		}
		printf("%d\n",kuskal(n,m));
	}
	return 0;
} 

郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。