我的第一道java_A+B

JAVA——A+B

——————我的第一道JAVA

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 241566    Accepted Submission(s): 46567


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

 

Sample Input
2 1 2 112233445566778899 998877665544332211
 

 

Sample Output
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
 
 大数题,我的第一道JAVA
 
技术分享
import java.util.Scanner;
import java.math.BigInteger;

public class Main {
    final int maxn=1000100;
    public static void main(String[] args){
        Scanner in=new Scanner(System.in);
        int T;
        T=in.nextInt();
        for(int i=1;i<=T;i++){
            BigInteger a,b,c;
            a=in.nextBigInteger();
            b=in.nextBigInteger();
            c=a.add(b);
            System.out.println("Case "+i+":");
            System.out.println(a.toString()+" + "+b.toString()+" = "+c.toString());
            if(i<T) System.out.println();
        }
    }
}
A+B

 

 

郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。