PAT A1042. Shuffling Machine (20)

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, H1, H2, ..., H13, C1, C2, ..., C13, D1, D2, ..., D13, J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (<= 20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:
2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47
Sample Output:
S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

思路:
S1-S13保存为1-13,H1-H13保存为101-113,其他类似每次加100保存。order[]保存变换后位置,再用一个数组temp[]保存变换后的内容,每次变换后都将temp[]内容重新赋给原数组s[]。输出时减100并加相应字母。
#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int main()
{
    int s[55], n, order[55], temp[55];
    for(int i = 1; i <= 54; i++)
    {
        if(i <= 13)
            s[i] = i;
        else if(i <=26)
            s[i] = i-13+100;
        else if(i <=39)
            s[i] = i-26+200;
        else if(i <=52)
            s[i] = i-39+300;
        else
            s[i] = i-52+400;
    }
    cin >> n;
    for(int i = 1; i <= 54; i++)
        cin >> order[i];
    for(int j = 0; j < n; j++)
    {
        for(int i = 1; i <= 54; i++)
            temp[order[i]] = s[i];
        for(int i = 1; i <= 54; i++)
            s[i] = temp[i];
    }

    for(int i = 1; i <= 54; i++)
    {

        if(s[i] < 100)
            cout << "S" << s[i];
        else if(s[i] < 200)
            cout << "H" << s[i]-100;
        else if(s[i] < 300)
            cout << "C" << s[i]-200;
        else if(s[i] < 400)
            cout << "D" << s[i]-300;
        else
            cout << "J" << s[i]-400;
        if(i <= 53)
            cout << " ";
    }
    return 0;
}


郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。