hdu5119——Happy Matt Friends

Happy Matt Friends

Time Limit: 6000/6000 MS (Java/Others)    Memory Limit: 510000/510000 K (Java/Others)
Total Submission(s): 150    Accepted Submission(s): 56


Problem Description
Matt has N friends. They are playing a game together.

Each of Matt’s friends has a magic number. In the game, Matt selects some (could be zero) of his friends. If the xor (exclusive-or) sum of the selected friends’magic numbers is no less than M , Matt wins.

Matt wants to know the number of ways to win.
 

Input
The first line contains only one integer T , which indicates the number of test cases.

For each test case, the first line contains two integers N, M (1 ≤ N ≤ 40, 0 ≤ M ≤ 106).

In the second line, there are N integers ki (0 ≤ ki ≤ 106), indicating the i-th friend’s magic number.
 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y indicates the number of ways where Matt can win.
 

Sample Input
2 3 2 1 2 3 3 3 1 2 3
 

Sample Output
Case #1: 4 Case #2: 2
Hint
In the ?rst sample, Matt can win by selecting: friend with number 1 and friend with number 2. The xor sum is 3. friend with number 1 and friend with number 3. The xor sum is 2. friend with number 2. The xor sum is 2. friend with number 3. The xor sum is 3. Hence, the answer is 4.
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:  5126 5125 5122 5121 5118

题解是高斯消元(真心不太会)
用了背包过的,再加个滚动数组,一开始纠结在前i个数异或最大,然后怎么都A不了,后来干脆全部把上限改成1 << 20,然后过了

#include <map>
#include <set>
#include <list>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

__int64 dp[2][1 << 22];
int num[44];

int main()
{
	int t, n, m, icase = 1;
	__int64 ans;
	scanf("%d", &t);
	while (t--)
	{
		memset (dp, 0, sizeof(dp));
		scanf("%d%d", &n, &m);
		for (int i = 1; i <= n; ++i)
		{
			scanf("%d", &num[i]);
		}
		dp[0][0] = 1;
		for (int i = 1; i <= n; ++i)
		{
			for (int j = 0; j <= (1 << 20); ++j)
			{
				dp[i % 2][j] = dp[1 - (i % 2)][j] + dp[1 - (i % 2)][j ^ num[i]];
			}
		}
		ans = 0;
		for (int i = m; i <= (1 << 20); ++i)
		{
			ans += dp[n % 2][i];
		}
		printf("Case #%d: %I64d\n", icase++, ans);
	}
	return 0;
}


郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。