HDU4925:Apple Tree

Problem Description
I’ve bought an orchard and decide to plant some apple trees on it. The orchard seems like an N * M two-dimensional map. In each grid, I can either plant an apple tree to get one apple or fertilize the soil to speed up its neighbors’ production. When a grid is fertilized, the grid itself doesn’t produce apples but the number of apples of its four neighbor trees will double (if it exists). For example, an apple tree locates on (x, y), and (x - 1, y), (x, y - 1) are fertilized while (x + 1, y), (x, y + 1) are not, then I can get four apples from (x, y). Now, I am wondering how many apples I can get at most in the whole orchard?
 

Input
The input contains multiple test cases. The number of test cases T (T<=100) occurs in the first line of input.
For each test case, two integers N, M (1<=N, M<=100) are given in a line, which denote the size of the map.
 

Output
For each test case, you should output the maximum number of apples I can obtain.
 

Sample Input
2 2 2 3 3
 

Sample Output
8 32
 

Author
BUPT


对于这种题 ,我只想说 ,推吧,少年!

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

__int64 a[105][105];

void set()
{
    int i,j;
    a[1][1] = 1;
    a[2][2] = 8;
    a[1][2] = 2;
    for(i = 3;i<=100;i++)
    a[i][i] = (8*(i-1)*(i-1));
    for(i = 1;i<=100;i++)
    {
        for(j = i+1;j<=100;j++)
        {
            if(i == 1)
            {
                if(j == 2)
                continue;
                else
            a[i][j] = a[i][j-1]+2;
            }
            else
            a[i][j] = a[i][j-1]+a[i][i]/(i-1);
        }
    }
}

int main()
{
    set();
    int t,n,m;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        if(n>m)
        swap(n,m);
        printf("%I64d\n",a[n][m]);
    }

    return 0;
}



HDU4925:Apple Tree,,5-wow.com

郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。