杭电 HDU 1061 Rightmost Digit

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 36818    Accepted Submission(s): 13950


Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the rightmost digit of N^N.
 
Sample Input
2 3 4
 

Sample Output
7 6
 
 
一开始超时:
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
  int  n;int T;
     cin>>T;
	 int t,sum;
  while(T--)
  {
	  sum=1;
	  scanf("%d",&n);
	  t=n%10;
	for(int i=1;i<=n;i++)
	{
		sum*=t;
		if(sum>10)
			sum%=10;
	}
  cout<<sum<<endl;
  }
  return 0;
}

那么找规律 发现数字循环,不过 有的循环节实在太长 ,一开始找错了 丫的。
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
  int  n;int T;
     cin>>T;
	 int ls[21]={1,4,7,6,5,6,3,6,9,0,1,6,3,6,5,6,7,4,9,0};
	while(T--)
	{
		cin>>n;
		if(!(n%20))
			cout<<0<<endl;
		else
			cout<<ls[n%20-1]<<endl;
	}
	return 0;
}

 

郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。