SGU - 302 - BHTML 1.0 (栈的应用)

302. BHTML 1.0

Time limit per test: 0.25 second(s)
Memory limit: 65536 kilobytes
input: standard
output: standard



The hypertext markup language BHTML 1.0 has only two paired tags. They are 技术分享UP技术分享 技术分享/UP技术分享 and 技术分享DOWN技术分享 技术分享/DOWN技术分享. The 技术分享UP技术分享 技术分享/UP技术分享 tag capitalizes all letters inside its body (between an open tag and a close one), and 技术分享DOWN技术分享 技术分享/DOWN技术分享 makes all inside the body letters lowercase. You are given the text consisting of latin letters and tags. Your task is to write the text right as it will be shown in the Bernet Explorer browser window. Tags in the text are arranged correctly, i.e. they form correct bracket sequence. If a letter lays inside several tags, its case is defined by the most inner tag.

Input
The input contains the string S with the text. The length of the string is a natural number not exceeding 1000. Tags are always written in uppercase.

Output
Write to the output text after the processing.

Example(s)
sample input
sample output
Thi<UP>sIs<DOWN>EaSY</DOWN>Pr<UP>O</UP>ble</UP>m 
ThiSISeasyPROBLEm 




Online Contester Team ? 2002 - 2010. All rights reserved.





思路:栈的应用,具体看代码;


AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <stack>
using namespace std;

char str[1005];

int main() {
	while(gets(str) != NULL) {
		stack<int> s;
		int len = strlen(str);
		for(int i = 0; i < len; i++) {
			if(str[i] == '<') {
				if(str[i+1] == 'U') { s.push(1); i += 3; }
				else if(str[i+1] == 'D') { s.push(2); i += 5; }
				else if(str[i+1] == '/') {
					s.pop();
					if(str[i+2] == 'U') i += 4;
					else if(str[i+2] == 'D') i += 6;
				}
			}
			else if(s.empty()) {
				printf("%c", str[i]);
			}
			else if(s.top() == 1) {
				if(str[i] >= 'a' && str[i] <= 'z') printf("%c", str[i]-32);
				else printf("%c", str[i]);
			}
			else if(s.top() == 2) {
				if(str[i] >= 'A' && str[i] <= 'Z') printf("%c", str[i]+32);
				else printf("%c", str[i]);
			}
		}
		printf("\n");
	}
	return 0;
}











郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。