hdu 1072 Nightmare BFS,第一次刷BFS的题,感好牛逼的。。。

Nightmare

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7758    Accepted Submission(s): 3723


Problem Description
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius‘ start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can‘t get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can‘t use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius‘ start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius‘ target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
 

Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
 

Sample Input
3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1
 

Sample Output
4 -1 13
我不想解释了太多了,http://blog.csdn.net/guodongxiaren/article/details/23552313
有大牛写了,我是照着他的写的,代码雷同度到达百分之九十~~~我还在成长中~~~~
代码:
<pre name="code" class="cpp">#include <cstdio>
#include <queue>
#include <cstring>

using namespace std ;
int map[10][10] , rest[10][10] , spend[10][10] , ans = -1;
int dir[4][2] = {1,0,-1,0,0,1,0,-1} ;
int n , m ;	//列与行 
queue<int> q;

bool judge(int x ,int y , int time)
{
	if(x<0||x>=n || y<0||y>=m) //坐标越界检查 
	{
		return false ;
	}
	if(map[x][y] == 0 || rest[x][y]>=time)//位置合理判断 
	{
		return false ;
	}
	return true ;
}

void BFS(int des)
{
	q.push(des) ;
	while(!q.empty())
	{
		int des = q.front();
		q.pop() ;
		int x = des/10 , y = des%10 ;
		if(rest[x][y] == 0)
			continue ;
		if(map[x][y] == 3)
		{
			if(ans == -1 || spend[x][y]<ans)
			{
				ans = spend[x][y] ;
			}
			continue ;
		}
		if(map[x][y] == 4)
		{
			rest[x][y] = 6 ;
			map[x][y] = 0 ;
		}
		for(int k = 0 ; k < 4 ; ++k)
		{
			int nextX = x + dir[k][0];
			int nextY = y + dir[k][1];
			if(judge(nextX,nextY,rest[x][y]-1))
			{
				q.push(nextX*10+nextY);
				rest[nextX][nextY] = rest[x][y]-1 ;
				spend[nextX][nextY] = spend[x][y]+1;
			}
		}
	}
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int des ;
		scanf("%d%d",&n,&m);
		memset(map,0,sizeof(map));
		memset(spend,0,sizeof(spend));
		memset(rest,0,sizeof(rest));
		for(int i = 0 ; i < n ; ++i)
		{
			for(int j = 0 ; j < m ; ++j)
			{
				scanf("%d",&map[i][j]);
				if(map[i][j] == 2)
				{
					rest[i][j] = 6 ;
					des = i*10 + j ;
				}
			}
		}
		
		ans = -1 ;
		BFS(des);
		printf("%d\n",ans) ;
	}
	return 0;
}



郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。