POJ 2531 Network Saboteur (DFS)

Network Saboteur
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 9385   Accepted: 4433

Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts. 
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks. 
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him. 
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000). 
Output file must contain a single integer -- the maximum traffic between the subnetworks. 

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.

Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90

Source

Northeastern Europe 2002, Far-Eastern Subregion
 
通过将vis[i]标记为1,0来将第i个分到1,0的两类里面,C[i][cur]表示第i台电脑到第cur台电脑的权值
到n时更新最大值
 
#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<stdlib.h>
#include<algorithm>
using namespace std;
const int MAXN=20+5;
const int INF=0x3f3f3f3f;
int C[MAXN][MAXN],vis[MAXN],n,ans,m;
void DFS(int cur,int sum)
{
    if(cur>n)
    {
        if(sum>ans)
            ans=sum;
        return ;
    }
    m=0,vis[cur]=1;
    for(int i=1;i<=cur;i++)
        if(vis[i]==0)
          m+=C[i][cur];
    DFS(cur+1,sum+m);

    m=0,vis[cur]=0;
    for(int i=1;i<=cur;i++)
        if(vis[i]==1)
            m+=C[i][cur];
    DFS(cur+1,sum+m);
}
int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
            scanf("%d",&C[i][j]);
    DFS(1,0);
    printf("%d\n",ans);
    return 0;
}
View Code

 

郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。