Poj(2352)——Stars(树状数组)

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 
技术分享

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it‘s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

这道题也是一道裸的树状数组题,适合新手练习,但是要把新算法转化成自己的想法总不是那么容易的。

这题的大致思路是:

从左到右,从下到上,然后分别给出星星,而星星的level就是在它下面和左边的星星个数,然后要你求出0-n-1的level的星星有几个。

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define maxn 32222
//这道题目很巧妙,首先是根据x的增长来的,然后再根据y的增长来排的; 
//所以这样就能理解为什么每次就只要求x之前的就好了 
int c[maxn];
int levels[maxn];
int lowbit(int x){
	return x&(-x);
}
//这里是对前x进行求和; 
int sum(int x){
	int res=0;
	while(x>0){	//注意这里是x>0,不能写成x>=0; 
		res+=c[x];
		x-=lowbit(x);
	}
	return res;
}
//这里的目的是给下标为pos的加上1,这样的话下次询问前面的就能够累加上去了; 
void update(int pos){
	while(pos<=32001){
		c[pos]++;
		pos+=lowbit(pos);
	}
}
int main(){
	int n,x,y;
	while(~scanf("%d",&n)){
		memset(levels,0,sizeof(levels));
		int tt=n;
		while(tt--){
			scanf("%d%d",&x,&y);
			levels[sum(x+1)]++;
			update(x+1);
		}
		for(int i=0;i<n;i++) printf("%d\n",levels[i]);
	}
}



郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。