ZOJ3787:Access System

For security issues, Marjar University has an access control system for each dormitory building.The system requires the students to use their personal identification cards to open the gate if they want to enter the building.

The gate will then remain unlocked for L seconds. For example L = 15, if a student came to the dormitory at 17:00:00 (in the format of HH:MM:SS) and used his card to open the gate. Any other students who come to the dormitory between [17:00:00, 17:00:15) can enter the building without authentication. If there is another student comes to the dorm at 17:00:15 or later, he must take out his card to unlock the gate again.

There are N students need to enter the dormitory. You are given the time they come to the gate. These lazy students will not use their cards unless necessary. Please find out the students who need to do so.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N (1 <= N <= 20000) and L (1 <= L <= 3600). The next N lines, each line is a unique time between [00:00:00, 24:00:00) on the same day.

Output

For each test case, output two lines. The first line is the number of students who need to use the card to open the gate. The second line the the index (1-based) of these students in ascending order, separated by a space.

Sample Input

3
2 1
12:30:00
12:30:01
5 15
17:00:00
17:00:15
17:00:06
17:01:00
17:00:14
3 5
12:00:09
12:00:05
12:00:00

Sample Output

2
1 2
3
1 2 4
2
2 3


 

 

简单模拟

 

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

struct node
{
    int h,m,s,no,flag;
} a[20005];

int abs(int a)
{
    if(a<0)
        return -a;
    return a;
}

int cmp(node a,node b)
{
    if(a.h!=b.h)
        return a.h<b.h;
    if(a.m!=b.m)
        return a.m<b.m;
    return a.s<b.s;
}

int work(int i,int j)
{
    int t1 = a[i].h*3600+a[i].m*60+a[i].s;
    int t2 = a[j].h*3600+a[j].m*60+a[j].s;
    return t1-t2;
}

int cmp2(node a,node b)
{
    return a.no<b.no;
}

int main()
{
    int t,n,k,i,j,tem;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&k);
        for(i = 1; i<=n; i++)
        {
            scanf("%d:%d:%d",&a[i].h,&a[i].m,&a[i].s);
            a[i].no = i;
            a[i].flag = 0;
        }
        sort(a+1,a+1+n,cmp);
        a[1].flag = 1;
        tem = 1;
        int cnt = 1;
        for(i = 2; i<=n; i++)
        {
            if(abs(work(i,tem))>=k)
            {
                a[i].flag = 1;
                tem = i;
                cnt++;
            }
        }
        sort(a+1,a+1+n,cmp2);
        int ff = 0;
        printf("%d\n",cnt);
        for(i = 1; i<=n; i++)
        {
            if(a[i].flag)
            {
                if(ff)
                    printf(" %d",i);
                else
                    printf("%d",i);
                ff = 1;
            }
        }
        printf("\n");
    }

    return 0;
}


 

ZOJ3787:Access System,古老的榕树,5-wow.com

郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。