【Linux学习】Makefile学习(二)

FatMouse‘ Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 40975    Accepted Submission(s): 13563


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1‘s. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
13.333 31.500


无聊刷的贪心水题,主要是研究c++的浮点型问题。

1.头文件里加#include<iomanip>。
2.cout<<setioflags(io::fixed)<<setprecision(位数)<<变量<<endl;


AC代码如下:

#include<iostream>
#include<algorithm>
#include<iomanip>
using namespace std;

struct H
{
    int x,y;
    double z;
}f[10005];

bool cmp(H a,H b)
{
    return a.z>b.z;
}

int main()
{
    int m,n;
    int i,j;
    while(cin>>m>>n,m!=-1&&n!=-1)
    {
        for(i=0;i<n;i++)
        {
            cin>>f[i].x>>f[i].y;
            f[i].z=(double)f[i].x/f[i].y;
        }
        sort(f,f+n,cmp);
        double sum=0;
        for(i=0;i<n;i++)
        {
            m-=f[i].y;
            if(m>0)
            {
                sum+=(double)f[i].x;
            }
            else
            {
                sum+=f[i].z*(m+f[i].y);
                break;
            }
        }
        cout<<setiosflags(ios::fixed);
        cout<<setprecision(3)<<sum<<endl;
    }
	return 0;
}



【Linux学习】Makefile学习(二),古老的榕树,5-wow.com

郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。